Error synchronization and weird names in the UI after a while

View previous topic View next topic Go down

Error synchronization and weird names in the UI after a while

Post  wojtek on Sat Sep 11, 2010 10:07 am

I've been using your gadged for a while and only recently it started acting up on me. After few days of not restrating my OS it stops to synchronize, revert the font to the default value (but only font, and it doesn't react to changes). And everything in the UI has "x" in front of the name.

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sat Sep 11, 2010 10:07 am

a link to the screenshot: http: // unir.se / google.png

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Sat Sep 11, 2010 4:42 pm

The "x"s mean it couldn't set language.

If it happens again, please send the log to ilab at windowslive.com. Perhaps you could switch on trace mode. It will create a lot of logs but gives more info to me

Thanks

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sun Sep 12, 2010 10:13 pm

It just happened again. Unfortunately link from Preferences doesn't open any file as usual. Can you tell me where to look for the log?

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Sun Sep 12, 2010 11:29 pm

It is c:\Users\[yourOSuser]\AppData\Local\Temp\Google_Calendar_Agenda\debug.log

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Thu Sep 16, 2010 5:59 pm

I know now what's the problem. I've set up my computer recently to clear all temp folder at startup (by removing the folder itself, not removing files inside - it's way easier). And Google Agenda relay on this folder and it's unable to create such if it's not present. Solutions:
- check whether Temp folder exists, if not - create it?

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Thu Sep 16, 2010 6:12 pm

Well, I don't think it is the task of applications to create the OS level temp directory. It is supposed to exist. The gadget actually checks whether its directory under $TEMP exists and creates it if not. I suggest recreating $TEMP after deleting it, if you want to remove it together with its content for some reason.

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sat Sep 18, 2010 12:35 pm

It's kinda not system level... Sorry, but trying to use something only on the assumption that it suppose to be there it's not very wise...

Anyhow - problem is not solved (at least there is other problem unrelated to the missing temp):

pastebin.com / HXGaXWr3 (delete spaces)

and it stucks with this error...

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Sat Sep 18, 2010 2:31 pm

wojtek wrote:It's kinda not system level... Sorry, but trying to use something only on the assumption that it suppose to be there it's not very wise...

Okay, it depends. I meant c:\Users\[yourOSuser]\AppData\Local\Temp is missing, that is operating system (well, user base) level, and supposing its existence is perfectly reasonable. You can assume that $WINDOWS is there, right? Or should I install one if not? If you mean c:\Users\[yourOSuser]\AppData\Local\Temp\Google_Calendar_Agenda is missing, then you are right, but this IS recreated by the gadget automatically.


Anyhow - problem is not solved (at least there is other problem unrelated to the missing temp):

pastebin.com / HXGaXWr3 (delete spaces)

and it stucks with this error...

Sorry but I don't have a clue what you wrote here... if you can send me a log file (trace mode) then do it please.
Have you tried reinstalling the gadget? You might have removed its language files also Very Happy

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sat Sep 18, 2010 5:32 pm

For me? It's more reasonable to just check it in the code than assume - less errors (;

About the log - it's but I cannot sent links (or it was problematic last time) :O

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sat Sep 18, 2010 5:33 pm

yes... every link I post get truncated... therefore I put extra spaces there to remove:

http:// pastebin.com /HXGaXWr3 (remove space after :// and before next slash) (:

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Sat Sep 18, 2010 8:32 pm

Ah...

Unfortunately, this is not trace mode log as I asked. Could you please set trace mode on and send the log afterwards? You can send it to ilab at windowslive.com. Thanks.

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sun Sep 19, 2010 9:20 am

OK, As you may remember - after the problem appears the settings are reset so even tho I turned trace before it got disabled. I've enabled it, the file "trace" was created but it's empty after several hours... (not to mention that the settings in general are not taken into consideration by the app whatsoever).

I think it's time to search for another app to show my calendar on the desktop, possilby with less errors :/

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Sun Sep 19, 2010 10:50 am

FYI, detailed trace log is also written to the standard log file, the file with name "trace" denotes the gadget that it should generate detailed log. So you can send me debug.log.

However, you can choose another app if you feel like Smile

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Sun Sep 19, 2010 3:35 pm

debug.log also contained the same thing... I've removed the gadget and added it again and the trace option works now... will see...

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  wojtek on Mon Sep 20, 2010 5:01 pm

The error:

[code]
2010-09-19T15:10:58: [Google.x265x]
ST: Internal Server Error
RT: <html><head><meta http-equiv="content-type" content="text/html;charset=UTF-8">
<title>BÓąd</title>
<style type="text/css">body {font-family: arial,sans-serif}</style></head>
<body text="#000000" bgcolor="#ffffff"><table border="0" cellpadding="2" cellspacing="0" width="100%"><tr><td rowspan="3" width="1%" nowrap><b><font face="times" size="10"><font color="#0039b6">G</font> <font color="#c41200">o</font> <font color="#f3c518">o</font> <font color="#0039b6">g</font> <font color="#30a72f">l</font> <font color="#c41200">e</font></font>  </b></td>
<td> </td></tr>
<tr><td bgcolor="#3366cc"><font face="arial,sans-serif" color="#ffffff"><b>BÓąd</b></font></td></tr>
<tr><td> </td></tr></table>
<blockquote>Nie mo࠮a uzyska桤ost뱵 do ߹danego kalendarza</blockquote>
<p></p>
<div style="background:#3366cc; width:1px; height:4px"></div></body></html>
2010-09-19T15:10:58: [Main.x7125x] 500 / Internal Server Error / <html><head><meta http-equiv="content-type" content="text/html;charset=UTF-8">
<title>BÓąd</title>
<style type="text/css">body {font-family: arial,sans-serif}</style></head>
<body text="#000000" bgcolor="#ffffff"><table border="0" cellpadding="2" cellspacing="0" width="100%"><tr><td rowspan="3" width="1%" nowrap><b><font face="times" size="10"><font color="#0039b6">G</font> <font color="#c41200">o</font> <font color="#f3c518">o</font> <font color="#0039b6">g</font> <font color="#30a72f">l</font> <font color="#c41200">e</font></font>  </b></td>
<td> </td></tr>
<tr><td bgcolor="#3366cc"><font face="arial,sans-serif" color="#ffffff"><b>BÓąd</b></font></td></tr>
<tr><td> </td></tr></table>
<blockquote>Nie mo࠮a uzyska桤ost뱵 do ߹danego kalendarza</blockquote>
<p></p>
<div style="background:#3366cc; width:1px; height:4px"></div></body></html>
2010-09-19T15:11:43: [Main.x3419x]
2010-09-19T15:12:43: [Main.x3419x]
[code]

Basically it says:
"Error, cannot access selected calendar"

wojtek
Guest


Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Admin on Mon Sep 20, 2010 6:20 pm

Hello!

I suppose this "cannot access selected calendar" thing is not related to your previous posts.

Specifically for this issue, please see this FAQ post

Admin
Admin

Posts : 690
Join date : 2008-10-13

View user profile http://ilab.forumotion.net

Back to top Go down

Re: Error synchronization and weird names in the UI after a while

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum